File faad2.spec of Package faad2 (Revision 1301112e29fe54db11cb9a73a082828d)

Currently displaying revision 1301112e29fe54db11cb9a73a082828d , Show latest

105
 
1
#
2
# spec file for package faad2
3
#
4
# Copyright (c) 2020 Packman Team <packman@links2linux.de>
5
# Copyright (c) 2005-2020 Manfred Tremmel <Manfred.Tremmel@iiv.de>
6
# Copyright (c) 2004-2005 Rainer Lay <rainer@links2linux.de>
7
# Copyright (c) 2003 Henne Vogelsang <henne@links2linux.de>
8
#
9
# All modifications and additions to the file contributed by third parties
10
# remain the property of their copyright owners, unless otherwise agreed
11
# upon. The license for this file, and modifications and additions to the
12
# file, is the same license as for the pristine package itself (unless the
13
# license for the pristine package is not an Open Source License, in which
14
# case the license is the MIT License). An "Open Source License" is a
15
# license that conforms to the Open Source Definition (Version 1.9)
16
# published by the Open Source Initiative.
17
18
# Please submit bugfixes or comments via https://bugs.links2linux.org/
19
#
20
21
22
%define so_version  2
23
%define so_name     libfaad%so_version
24
%define so_name_drm libfaad_drm%so_version
25
Name:           faad2
26
Version:        0
27
Release:        0
28
Summary:        Freeware Advanced Audio (AAC) Decoder including SBR decoding
29
License:        GPL-2.0-or-later
30
URL:            https://github.com/knik0/faad2
31
Source0:        %name-%version.tar
32
BuildRequires:  cmake >= 3.15
33
BuildRequires:  pkgconfig
34
Requires:       %so_name = %version-%release
35
36
%description
37
FAAD2 is a HE, LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder.
38
FAAD2 includes code for SBR (HE AAC) decoding.
39
40
%package -n %so_name
41
Summary:        Shared library part of faad2
42
43
%description -n %so_name
44
FAAD2 is a HE, LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder.
45
FAAD2 includes code for SBR (HE AAC) decoding.
46
47
%package -n %so_name_drm
48
Summary:        DRM shared library part of faad2
49
50
%description -n %so_name_drm
51
FAAD2 is a HE, LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder.
52
FAAD2 includes code for SBR (HE AAC) decoding.
53
The shared library part of faad2-drm
54
55
%package devel
56
Summary:        Development files of the FAAD 2 AAC decoder
57
Requires:       %so_name = %version-%release
58
Requires:       %so_name_drm = %version-%release
59
Obsoletes:      libfaad2-devel < %version-%release
60
Provides:       libfaad2-devel = %version-%release
61
Obsoletes:      libfaad-devel < %version-%release
62
Provides:       libfaad-devel = %version-%release
63
64
%description devel
65
FAAD2 is a HE, LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder.
66
FAAD2 includes code for SBR (HE AAC) decoding.
67
Header files and development documentation for libfaad.
68
69
%prep
70
%autosetup -p1
71
72
%build
73
CFLAGS='%optflags -DBUILD_DATE=\"\"'
74
%cmake
75
%cmake_build
76
77
%install
78
%cmake_install
79
80
%ldconfig_scriptlets -n %so_name
81
%ldconfig_scriptlets -n %so_name_drm
82
83
%files
84
%doc ChangeLog
85
%license COPYING
86
%_bindir/faad
87
%_mandir/man1/faad.1%{?ext_man}
88
89
%files -n %so_name
90
%_libdir/libfaad.so.%so_version
91
%_libdir/libfaad.so.%so_version.*
92
93
%files -n %so_name_drm
94
%_libdir/libfaad_drm.so.%so_version
95
%_libdir/libfaad_drm.so.%so_version.*
96
97
%files devel
98
%_includedir/faad.h
99
%_includedir/neaacdec.h
100
%_libdir/libfaad.so
101
%_libdir/libfaad_drm.so
102
%_libdir/pkgconfig/%name.pc
103
104
%changelog
105